Order Management functions are not available when using the basic browser login.

The Freedom Investments trading area uses advanced HTML that can been seen using the current release versions of the Microsoft Internet Explorer and Netscape Navigator or Communicator. Features like table colors and row size, text alignment and wrapping, Java Script, and Frames are required for full access in this area. Without full access, order management functions will not be available.

The current browsers available with AOL versions 2.5 and 3.0 for Windows 3.1 do NOT support all of these enhanced features. If you are using these AOL browsers it may be worth your time to download one of the above mentioned browsers to view this site.

If you choose not to upgrade, you can still access most of the content of this area through our basic browser login page. At present, The basic browser site does not support entering new orders, canceling orders, or changing orders. Also, a few other features such as context sensitive help and selection of table data by symbol will not be available. These functions require Java Script.

If you have Windows 95, and you use AOL's browser, you should verify that you are using AOL for Windows 95 from the 'Help | About AOL' menu. This version fully supports this site.

Contact an AOL representative for assistance if you are not sure of your version or if you need to upgrade it from the AOL for Windows version. They can also assist you with downloading a Netscape product or the Microsoft Internet Explorer which are available for free through AOL.

If you would like to speak to an AOL representative who can help you with these issues you can try the following numbers: